2004-09-14-2217Z


Got home yesterday morning sometime. Was treated to lobster dinner and other nice things from Someone Very Special and today worked on getting my websites back online. And they are!

If you have a wireless PalmOS device, either wifi or bluetooth, and a wireless router such as a 2wire or linksys, and are getting the infamously helpful message "invalid network settings" when trying to browse the web or send email, this is for you. Google on the above and you'll find a lot of solutions that involve installing software on your Palm device and/or doing multiple hard resets (to factory defaults) of both the palmtop and router! While I'm not denying that such steps may be necessary in some cases, I doubted that I would need to do it. In the first place, I found many places in my travels where I could use free APs with no problem after autodiscovery located them. Secondly, specifying a DNS IP in the advanced network settings on the Clié usually fixed it. And lastly, I could in such cases usually connect to a website by IP number.

All the above indicated that something is fucked in Palm's DHCP client software. I've been assuming that by making the DHCP server advertise its own IP as the default DNS server (as long as it can serve in that capacity!) it would solve the problem. And my testing now seems to indicate that it does! At least with the WRT54G. Still having some issues with the 2wire.

Back to blog or home page

last updated 2013-01-10 20:30:50. served from tektonic